不适用于 : http://example.com/
非标准端口号上的何解 robots.txt 文件只对通过这些端口号提供的内容有效。并为其使用支持的谷歌规范协议 。就 Google 搜索而言 ,何解确定某项规则是谷歌规范否适用于网站上的特定网址。此网址不需要与 robots.txt 文件位于同一主机上 。何解对同一个主机 、谷歌规范
如果我们能够确定,何解指定的谷歌规范抓取工具没有抓取限制 。
不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的何解 robots.txt 只对该子网域有效。请先阅读我们的谷歌规范 robots.txt 简介。则 Google 抓取工具会在内部合并这些组。何解Bing 和其他主流搜索引擎支持有限形式的谷歌规范通配符。这些指令始终以 directive: [path] 的何解形式指定,
disallow :不可抓取的谷歌规范网址路径。Google 会假定没有任何抓取限制。这意味着,
robots.txt 文件中列出的规则只适用于该文件所在的主机、响应无效、结尾的通配符会被忽略 。其中 [path] 可以选择性使用。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),example.com 的 robots.txt 文件可能如下所示:
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,例如,
匹配项 :
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项:
/fish
/fish.html
/Fish/Salmon.asp
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组 ,Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,
| 错误处理和 HTTP 状态代码 | |||||||||||||||||||||||||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件 。 | ||||||||||||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。建议为网站上的每个网址提供 503 HTTP 状态代码 。并且只使用有效行 。请在注释前面加上 # 字符 。Google 可能会忽略不属于 UTF-8 范围的字符, 用法 : sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。Google 、如果下载的内容是 Html 格式而非 robots.txt 规则 ,但可能仍会将其网址编入索引并将其显示在搜索结果中 ,它也可以在共享主机名下使用。因为存在多个匹配规则时 ,路径值必须以 / 开头来表示根目录,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较 。 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容, | ||||||||||||||||||||||||||||
| /* | 等同于 /。HTTPS 和 FTP
。如果未指定路径,Javascript 或元刷新型重定向)
。抓取工具不会检查子目录中的 robots.txt 文件。Google 将使用限制性最弱的规则 。HTTPS 为 443
,这意味着抓取将不受限制 。因为 allow 规则仅适用于根网址
。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。Google 会使用限制性最弱的规则。 这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。 匹配项: /filename.php /folder/filename.php 不匹配项: /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP | ||||||||||||||||||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。系统在处理时会将其视为服务器错误 。可将适用于多个用户代理的规则组合在一起。其他组会被忽略。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。 | ||||||||||||||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm, | ||||||||||||||||||||||||||||
| Googlebot News(抓取图片时) | 抓取图片时
,协议和端口号上的所有子目录中的所有文件有效
。下面说明了抓取工具如何理解之前的 robots.txt 代码段 : user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础 , disallow 指令的值区分大小写。googlebot/1.2 和 googlebot* 均等同于 googlebot)。且无需进行网址编码 。抓取工具会忽略不含路径的指令。例如, sitemap:站点地图的完整网址。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法 :
错误处理和 HTTP 状态代码在请求 robots.txt 文件时,因为它更具体 。这些通配符包括: * 表示出现 0 次或多次的任何有效字符。 | ||||||||||||||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容
。 allow 指令的值区分大小写。 Google 支持以下字段: user-agent:标识相应规则适用于哪些抓取工具 。 | ||||||||||||||||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3。因为它与网址中的字符匹配得更多, allow 和 disallow 字段也称为指令。 | ||||||||||||||||||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应 , | ||||||||||||||||||||||||||||
| /$ | 仅匹配根目录 。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。有关原始草稿标准的信息 ,即使有相关抓取工具的对应条目,因此更具体。如果没有缓存副本,已缓存的响应可由各种不同的抓取工具共享。系统会忽略行开头和结尾的空格。 | ||||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向, | ||||||||||||||||||||||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page,如果规则(包括使用通配符的规则)存在冲突, | ||||||||||||||||||||||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时, | ||||||||||||||||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。另请参阅 RFC 3492。直到获得非服务器错误的 HTTP 状态代码 。可以选择是否使用空格,可以创建包含相应规则的 robots.txt 文件。这意味着以下 robots.txt 代码段被视为一个组 ,将已排除的内容放在一个单独的目录中 。 | ||||||||||||||||||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。请参阅 REP 的第 2.1 节
。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,# 字符后面的所有内容都会被忽略。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。常见格式为 <field>:<value><#optional-comment>。重置或断开连接、抓取工具会根据规则路径的长度使用最具体的规则 。 和其他网址一样,但不显示摘要。在此情况下 , 对于路径值,但该文件可能是共享的 ,如果连续 30 天以上无法访问 robots.txt ,为此 ,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。请查看 IETF Data Tracker 。因为组 1 是最具体的组。缓存时间可能会延长 。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。 sitemap 字段的值区分大小写 。结尾的通配符会被忽略 。在抓取某一网站之前 , 此网址必须是完全限定网址 ,并忽略超过该上限的内容 。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析) 。 | ||||||||||||||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径。 allow:可抓取的网址路径 。因为它更具体 。如果 robots.txt 文件的字符编码不是 UTF-8, | ||||||||||||||||||||||||||||
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,只有一个组是有效的。任何更低级别的网址均可抓取。Google 会使用限制性最弱的规则。503 (service unavailable) 错误会导致非常频繁的重试操作。端口号 、某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,该指令将被忽略 。默认情况下,有助于提高可读性。Google 会尝试抓取 robots.txt 文件,例如 ,
Google 的自动抓取工具支持 REP(robots 协议) 。 例如,我们会将该状态代码解释为 404 (not found)。
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。一个冒号和一个值组成 。Google 会尝试解析内容并提取规则 , |
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80 , 例如 : user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明 ,抓取工具会使用标准 RETR (RETRIEVE) 命令,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),从而确定正确的规则组 。若要添加注释, 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,您还可以找到关于创建 robots.txt 文件的提示 ,所有非匹配文本都会被忽略(例如, $ 表示网址结束。 |
